GraSu Community

Înregistrează-te !
E rapid și ușor !
Scapi de reclame si vizualizezi tot conținutul forumului
Postezi mesajele tale
Primesti ajutor din partea comunității
(peste 1200 membri !!)

LINEUP ASII # Girls


Jucator 1
Jucator 2
Jucator 3
Jucator 4
Jucator 5
ASII # Girls
Adversar # Detalii
vs DW * #      
vs DsWW #      
vs gxGw #      
ASII # Girls
Adversar # Rezultat
vs R0k #      3-16
vs uSp #      16-6
vs neXt!LadiEs #      15-16
GraSu.LaLeagane.Ro

Redirecte GraSu


Reprezentarea algoritmilor (structuri pseudocod)

In jos

Reprezentarea algoritmilor (structuri pseudocod)

Mesaj Scris de faNta la data de Sam Aug 01, 2009 11:59 pm

Algoritmii se pot reprezenta prin:
-scheme logice
-pseudocod
-limbaj de programare

Pseudocodul foloseste cuvinte cheie pentru a exprima instructiunile care se dau unui calculator în vederea rezolvarii unei clase de probleme.

1) Început arata de unde porneste pseudocodul
Sfârsit arata unde se termina pseudocodul
2) Citeste si Scrie se numesc instructiuni de intrare-iesire
Citeste permite introducerea datelor iar Scrie permite afisarea datelor
3) A=B se numeste instructiune de atribuire si se foloseste pentru calcularea anumitor formule: "valoarea lui B se atribuie lui A".
4) Daca C
atunci A
altfel B
Sfârsit_Daca

Aceasta este o structura alternativa. Explicatie: Daca conditia C este îndeplinit? (adevarata) atunci se execut? A altfel se executa B, iar Sfârsit_Daca delimiteaza structura alternativa.
5) Structurile repetitive sunt:
- conditionata la inceput (cât_timp)
Cât_timp C
executa[u] A
[u]Sfârsit_cât_timp
Cât timp conditia C este îndeplinita (adevarata) se executa A, iar Sfârsit cât_timp încheie structura repetitiva.

- conditionata la sfârsit (pâna_când)
Repeta A
Pâna_când C
Se repet? A pâna când conditia C devine adevarata.

- cu numar cunoscut de pasi (pentru)
Pentru contor=valoare initiala,valoare finala
executa A
Sfârsit_pentru
Contor ia valoarea initiala si se executa A pâna când contor ajunge la valoarea finala.
avatar
faNta
♥ FAN ASII ♥


Sus In jos

Sus


 
Permisiunile acestui forum:
Nu puteti raspunde la subiectele acestui forum